libopenmetaverse
  1. libopenmetaverse
  2. LIBOMV-566

ObjectGrabPacket ToBytesMultiple() not working

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.7.0
    • Component/s: Networking
    • Labels:
      None
    • Severity:
      Showstopper
    • Environment:
      All
    • Steps to Reproduce:

      Run TestClient thru WinGridProxy

      touch prim-UUID

      Notice no ObjectGrabPacket is sent

      Show
      Run TestClient thru WinGridProxy touch prim-UUID Notice no ObjectGrabPacket is sent

      Description

      ObjectGrabPacket ToBytesMultiple() not working
      For now a workarround is

      HasVariableBlocks = false;
      in the contructor.

      Possibly other packets are broken in simular way

        Issue Links

          Activity

          Jim Radford added a comment -

          The issue is with both the ObjectGrabPacket and ObjectDeGrab packet not populating the SurfaceInfoBlock before the packet it sent. I'm going to create overloads that allow this information to be specified, otherwise default data will be sent in that block

          Jim Radford added a comment -

          Our packet packer doesn't appear to like null variable blocks being sent.

          The overlying bug has been fixed in r2833


            People

            • Assignee:
              Jim Radford
              Reporter:
              Douglas R Miles
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: